Issues with issues with displaying the leave balance and carry over calculation
Incident Report for Calamari
Resolved
We've restored 100% accounts. Right now, we are monitoring systems.
Posted Nov 19, 2024 - 16:52 CET
Update
We've restored 100% of accounts in the US and ASIA regions and are consequently restoring the data for clients in the EU. Currently, we've fixed approximately 80% of affected accounts in EU.
Posted Nov 19, 2024 - 09:30 CET
Update
We are consequently restoring the data. Currently, we've fixed approximately 50% of affected accounts.
Posted Nov 18, 2024 - 17:08 CET
Update
We are consequently restoring the data. Currently, we've fixed approximately 25% of affected accounts.
Posted Nov 18, 2024 - 15:06 CET
Update
We are consequently restoring the data. Currently, we've fixed approximately 15% of affected accounts. The ETA for correcting balances will take longer than we expected.
Posted Nov 18, 2024 - 13:33 CET
Update
We are consequently restoring the data from the moment before our last release. The ETA for correcting balances in all accounts is 60-90 minutes.
Posted Nov 18, 2024 - 12:46 CET
Monitoring
We are consequently restoring the data from the moment before our last release. The process of restoring the data is in the production environment. Carry-over balances will be fixed in the next 30-60 min for the first group of our clients.
Posted Nov 18, 2024 - 11:38 CET
Update
We've found a solution to prevent the problem from spreading—it is currently rolling out to the production environment. We are still working on a solution for recalculating carry-over to the correct amount.
Posted Nov 18, 2024 - 10:46 CET
Update
We are working on a solution to ensure the consistency of all our clients' data. We still do not have an ETA for solving the problem, but we will let you know as soon as we find one.
Posted Nov 18, 2024 - 10:23 CET
Identified
We found the cause of the issue and are working on a solution. The problem is related to our recent release - improvements in the carry-over engine.
Posted Nov 18, 2024 - 09:50 CET
Investigating
We are currently investigating the issue.
Posted Nov 18, 2024 - 02:00 CET
This incident affected: Web Apps - EU, Web Apps - US, and Web Apps - ASIA.